Paleo-Electronics

Clueless Idiots and High Voltage Vacuum Tubes Really Do Mix!

Paleo-Electronics header image 4

Entries from February 29th, 2008

Redo-ing the Mallory T8 Attenuator

February 29th, 2008 · No Comments · Uncategorized

You may recall that I ended this post : Mods to the working GA-5 with a problem. The problem was that like a bonehead, I didn’t try to dry fit any of it together and once the T8 was in place, it was hitting the PT. So I had to rip the damn thing out. […]

[Read more →]

Tags:

Debugging the GA-5T : A bit hasty…

February 21st, 2008 · 1 Comment · Amp Repair

So yes, I have removed the hum, and to a large degree the amp appears to be working well, but I noticed that bass notes got kind of farty sometimes and some specific notes would warble all over. Weird…  I’ll be putting the output section up on the scope again soon to see if I […]

[Read more →]

Tags:

Debugging the GA-5T : I never thought I would write this…

February 19th, 2008 · 14 Comments · Amp Repair

But I have done it! The amp sounds great. Some contact cleaner, a 3 prong mod and then I’ll button up the cab and give it a final run through, but I think I finally got it. I’ll save the final bit for last, because I want to do a quick walk through all the […]

[Read more →]

Tags: ··

Debugging the GA-5T : A new beginning

February 18th, 2008 · No Comments · Amp Repair

As you’ll have probably guessed by now, I don’t really know what I am doing. The GA-5T had a nasty buzzing that was independent of volume. So I re-did the power filter caps and now I have a hiss/buzz that is dependent on volume. I have run through with a DMM and every voltage is […]

[Read more →]

Tags: ······